After I release the version 0.1, some people told me that it would be better that use jquery_
as the helpers' prefix. The reason is that the helpers with jquery_
prefix are more readable. I accepted this suggestion and from version 0.2 on, each helper will use jquery_
as its prefix.
This change, of course, is compatible with the jq_
prefix because I use the alias_method
to make them compatible. That's why Ruby is so popular -- powerful, elegant, and easy. :-p
Wednesday, September 26, 2007
Prefix jq_ OR jquery_ ?
Subscribe to:
Post Comments (Atom)
6 comments:
I love Ruby and JQuery. I'll have to check out your stuff.
Hi ericsk.
I found little mistake in jq4r.rb.
lacking return sentence at jquery_remote_func.
a simple solution.
add return func.
Index: lib/jq4r.rb
===================================================================
--- lib/jq4r.rb (revision 15)
+++ lib/jq4r.rb (working copy)
@@ -215,6 +215,7 @@
func = "#{func}; #{options[:after]}" if options[:after]
func = "if (#{options[:condition]}) { #{func}; }" if options[:condition]
func = "if (confirm('#{escape_javascript(options[:confirm])}')) { #{func}; }" if options[:confirm]
+ func
end
alias_method :jq_remote_func, :jquery_remote_func
Hope this helps.
Forgive my English.
@noriaki
Thanks for your help! I will patch it after I go back Taiwan.
BTW, are you a japanese? I'm traveling in Tokyo, now :-p
@noriaki
I've fixed in revision 16
Hi
Your project is a very good idea, since prototype seems to be worse than jquery.
Hoping in the future, rails will integrate jquery as it does for protype.
So, many thanks to you for beginning this job!
Who knows where to download XRumer 5.0 Palladium?
Help, please. All recommend this program to effectively advertise on the Internet, this is the best program!
Post a Comment